From 5a4011711ab6e9aa1ac4d2b86b1afc39763a2552 Mon Sep 17 00:00:00 2001 From: Pierre Raybaut <1311787+PierreRaybaut@users.noreply.github.com> Date: Wed, 21 Oct 2026 06:47:17 +0200 Subject: [PATCH 1/2] Widen NumPy and SciPy bounds and configure Dependabot Allow NumPy 2.5.4 and SciPy 1.18.1 without raising minimum versions. Keep requirements synchronized and schedule grouped scientific range updates. Assisted-by: GPT-6.1 Sol --- .github/dependabot.yml | 18 ++++++++++++++++++ pyproject.toml | 4 ++-- requirements.txt | 4 ++-- 3 files changed, 22 insertions(+), 4 deletions(-) create mode 100644 .github/dependabot.yml diff --git a/.github/dependabot.yml b/.github/dependabot.yml new file mode 100644 index 00000000..10f44716 --- /dev/null +++ b/.github/dependabot.yml @@ -0,0 +1,18 @@ +version: 2 +updates: + - package-ecosystem: pip + directory: / + target-branch: develop + schedule: + interval: weekly + # Preserve minimum versions and widen only the scientific compatibility bounds. + versioning-strategy: widen + allow: + - dependency-name: numpy + - dependency-name: scipy + - dependency-name: scikit-image + - dependency-name: pandas + - dependency-name: pywavelets + groups: + scientific-stack: + patterns: ["*"] diff --git a/pyproject.toml b/pyproject.toml index a679f2d7..692d54ab 100644 --- a/pyproject.toml +++ b/pyproject.toml @@ -34,8 +34,8 @@ classifiers = [ requires-python = ">=3.9, <4" dependencies = [ "guidata >= 3.16.0", - "NumPy >= 1.22, < 2.5", - "SciPy >= 1.10.1, < 1.17", + "NumPy >= 1.22, < 2.6", + "SciPy >= 1.10.1, < 1.19", "scikit-image >= 0.19.2, < 0.27", # Not built for Pyodide (WebAssembly): tifffile then reads uncompressed TIFF "imagecodecs >= 2024.12.30; sys_platform != 'emscripten'", diff --git a/requirements.txt b/requirements.txt index e8d21829..9e71f9a3 100644 --- a/requirements.txt +++ b/requirements.txt @@ -1,8 +1,8 @@ Coverage -NumPy >= 1.22, < 2.5 +NumPy >= 1.22, < 2.6 PyQt5 PyWavelets >= 1.2, < 2.0 -SciPy >= 1.10.1, < 1.17 +SciPy >= 1.10.1, < 1.19 babel build guidata >= 3.16.0 From 7555a836acd5f308fbe77d1bd20b96c3789fe629 Mon Sep 17 00:00:00 2001 From: Pierre Raybaut <1311787+PierreRaybaut@users.noreply.github.com> Date: Wed, 21 Oct 2026 07:11:02 +0200 Subject: [PATCH 2/2] Keep compatibility updates independent of Dependabot Remove the proposed pip automation after verifying that Dependabot can select an older Python interpreter from the supported range and miss newer scientific releases. Keep this PR focused on the requested compatibility bounds. Assisted-by: GPT-6.1 Sol --- .github/dependabot.yml | 18 ------------------ 1 file changed, 18 deletions(-) delete mode 100644 .github/dependabot.yml diff --git a/.github/dependabot.yml b/.github/dependabot.yml deleted file mode 100644 index 10f44716..00000000 --- a/.github/dependabot.yml +++ /dev/null @@ -1,18 +0,0 @@ -version: 2 -updates: - - package-ecosystem: pip - directory: / - target-branch: develop - schedule: - interval: weekly - # Preserve minimum versions and widen only the scientific compatibility bounds. - versioning-strategy: widen - allow: - - dependency-name: numpy - - dependency-name: scipy - - dependency-name: scikit-image - - dependency-name: pandas - - dependency-name: pywavelets - groups: - scientific-stack: - patterns: ["*"]