From 39604444f2120cf2f9009c7de8fc577f67efe428 Mon Sep 17 00:00:00 2001 From: TensorDevLJ Date: Thu, 15 Oct 2026 13:37:21 +0530 Subject: [PATCH] Upgrade Pygments to >=2.20.0 in Sphinx requirements Resolves dependabot alert by bumping the pinned pygments version from 2.19.1 to >=2.20.0 in doc/sphinx/requirements.txt. Verified pygments 2.21.0 resolves, the 'tango' pygments_light_style used in conf.py is still available, and lexers used across the docs (python, c++, matlab, cmake, bash) still resolve correctly. Fixes #495 Co-authored-by: Cursor --- doc/sphinx/requirements.txt | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/doc/sphinx/requirements.txt b/doc/sphinx/requirements.txt index 4ab0adc75..3bd67f21d 100644 --- a/doc/sphinx/requirements.txt +++ b/doc/sphinx/requirements.txt @@ -76,7 +76,7 @@ requests>=2.32.3 # For PDF generation latexcodec==3.0.0 -pygments==2.19.1 +pygments>=2.20.0 # Development tools jinja2==3.1.6