From 8e8e1059ad2248fc58d3f5a45e9431d20131f7cc Mon Sep 17 00:00:00 2001 From: =?UTF-8?q?Micha=C5=82=20Niewrza=C5=82?= Date: Fri, 30 Oct 2026 09:31:54 +0100 Subject: [PATCH] Override postcss-selector-parser to fix security alert @tailwindcss/typography (up to 0.5.20) pins postcss-selector-parser to exactly 6.0.10, so Dependabot cannot update it to the patched 6.1.5. Force it with an npm override. Remove the override once typography drops the exact pin. Co-Authored-By: Claude Opus 5.5 Claude-Session: https://claude.ai/code/session_019njSSSsotmfQs11tZcaQkY --- package-lock.json | 33 ++++----------------------------- package.json | 3 +++ 2 files changed, 7 insertions(+), 29 deletions(-) diff --git a/package-lock.json b/package-lock.json index e757c83b1..172230752 100644 --- a/package-lock.json +++ b/package-lock.json @@ -5454,23 +5454,11 @@ "postcss": "^8.2.14" } }, - "node_modules/postcss-nested/node_modules/postcss-selector-parser": { - "version": "6.1.4", - "resolved": "https://registry.npmjs.org/postcss-selector-parser/-/postcss-selector-parser-6.1.4.tgz", - "integrity": "sha512-bIoJLOmjCO1S9XdY/DcnR5hJxvrDir1PbGChrzXG3vw0/FOliy/fA3dmdhQ441kah4gKv+TwckGzex6wNS5cnQ==", - "license": "MIT", - "dependencies": { - "cssesc": "^3.0.0", - "util-deprecate": "^1.0.2" - }, - "engines": { - "node": ">=4" - } - }, "node_modules/postcss-selector-parser": { - "version": "6.0.10", - "resolved": "https://registry.npmjs.org/postcss-selector-parser/-/postcss-selector-parser-6.0.10.tgz", - "integrity": "sha512-IQ7TZdoaqbT+LCpShg46jnZVlhWD2w6iQYAcYXfHARZ7X1t/UGhhceQDs5X0cGqKvYlHNOuv7Oa1xmb0oQuA3w==", + "version": "6.1.5", + "resolved": "https://registry.npmjs.org/postcss-selector-parser/-/postcss-selector-parser-6.1.5.tgz", + "integrity": "sha512-TEHFzb5KRDKaOgJ4TYE+0jyJtFbjLvkdVOu0fZ2b6MTWzoqZd4Le+61aEppWkvTlYePgOX4ATL1wsAIPMLTw6Q==", + "license": "MIT", "dependencies": { "cssesc": "^3.0.0", "util-deprecate": "^1.0.2" @@ -6488,19 +6476,6 @@ "postcss": "^8.0.0" } }, - "node_modules/tailwindcss/node_modules/postcss-selector-parser": { - "version": "6.1.4", - "resolved": "https://registry.npmjs.org/postcss-selector-parser/-/postcss-selector-parser-6.1.4.tgz", - "integrity": "sha512-bIoJLOmjCO1S9XdY/DcnR5hJxvrDir1PbGChrzXG3vw0/FOliy/fA3dmdhQ441kah4gKv+TwckGzex6wNS5cnQ==", - "license": "MIT", - "dependencies": { - "cssesc": "^3.0.0", - "util-deprecate": "^1.0.2" - }, - "engines": { - "node": ">=4" - } - }, "node_modules/text-table": { "version": "0.2.0", "resolved": "https://registry.npmjs.org/text-table/-/text-table-0.2.0.tgz", diff --git a/package.json b/package.json index aad77f629..5ec0e3dfe 100644 --- a/package.json +++ b/package.json @@ -54,5 +54,8 @@ "prettier": "^2.8.7", "prettier-plugin-tailwindcss": "^0.2.6", "sharp": "^0.35.5" + }, + "overrides": { + "postcss-selector-parser": "^6.1.5" } }