From 639c4696a892a65b204cfa3d0272994e524f9a2a Mon Sep 17 00:00:00 2001 From: Mridang Agarwalla Date: Fri, 11 Sep 2026 12:38:12 +1000 Subject: [PATCH] feat: require Ruby 3.1 or newer Ruby 3.0 reached end of life on 23 April 2024 and no longer receives security fixes. Raise the minimum supported Ruby to 3.1 by bumping required_ruby_version in the gemspec, aligning the RuboCop target, dropping 3.0 from the compatibility matrix and updating the README minimum requirements. This also unblocks the Dependabot security update for excon (GHSA-48rx-c7pg-q66r). The first patched release, excon 1.5.0, requires Ruby 3.1, so the resolver currently fails against the 3.0 floor. The excon bump itself is left for Dependabot to open. --- .github/workflows/integration.yml | 2 +- .rubocop.yml | 2 +- README.md | 2 +- zitadel-client.gemspec | 2 +- 4 files changed, 4 insertions(+), 4 deletions(-) diff --git a/.github/workflows/integration.yml b/.github/workflows/integration.yml index f45a4956..f5e01f6b 100644 --- a/.github/workflows/integration.yml +++ b/.github/workflows/integration.yml @@ -19,7 +19,7 @@ jobs: runs-on: ubuntu-latest strategy: matrix: - ruby-version: [ '3.0', '3.1', '3.2', '3.3', '3.4', '4.0' ] + ruby-version: [ '3.1', '3.2', '3.3', '3.4', '4.0' ] fail-fast: false steps: diff --git a/.rubocop.yml b/.rubocop.yml index 07506c54..02383d89 100644 --- a/.rubocop.yml +++ b/.rubocop.yml @@ -8,7 +8,7 @@ AllCops: - 'lib/zitadel/client/api/**/*' - 'vendor/**/*' NewCops: enable - TargetRubyVersion: 3.0 + TargetRubyVersion: 3.1 Layout/LineLength: Max: 130 diff --git a/README.md b/README.md index 4f7a64d5..cbd206fa 100644 --- a/README.md +++ b/README.md @@ -33,7 +33,7 @@ Zitadel website and obtain the necessary credentials to access the API. ### Minimum Requirements -Ensure you have Ruby 3 or higher installed. +Ensure you have Ruby 3.1 or higher installed. ## Using the SDK diff --git a/zitadel-client.gemspec b/zitadel-client.gemspec index 11dd6197..dd8204bb 100644 --- a/zitadel-client.gemspec +++ b/zitadel-client.gemspec @@ -14,7 +14,7 @@ Gem::Specification.new do |gemspec| gemspec.description = "Official Zitadel SDK for Ruby. Authenticate and access Zitadel's authentication and management APIs in Ruby." gemspec.license = 'Apache-2.0' - gemspec.required_ruby_version = '>= 3.0' + gemspec.required_ruby_version = '>= 3.1' gemspec.metadata = { 'rubygems_mfa_required' => 'true' } gemspec.add_dependency 'cgi', '>= 0.1'