You signed in with another tab or window. Reload to refresh your session.You signed out in another tab or window. Reload to refresh your session.You switched accounts on another tab or window. Reload to refresh your session.Dismiss alert
{{ message }}
Repository navigation
Raise the minimum supported Python version to 3.10 #1
The workspace is retiring Python 3.9 support. GitHub Actions ubuntu-latest is moving to Ubuntu 26.04, for which actions/setup-python does not provide CPython 3.9 builds. CPython 3.10 builds are available.
Scope
Raise Requires-Python and the Ruff target to 3.10 and update directly related documentation and next-release notes. Preserve the existing Python 3.11 Linux/Windows CI matrix; expanding plugin CI is explicitly a separate task.
Delivery and acceptance
Target branch: develop.
One dedicated PR for this repository, linked to this issue; preserve unrelated changes and published historical artifacts.
Validate changed behavior and metadata on the retained runtimes; report exact results and unavailable checks.
Keep ubuntu-latest; do not globally upgrade dependency bounds or add Python 3.15 support.
Merge only after applicable checks pass on the current PR head and branch protections are satisfied. Where no PR CI exists (Camera, Pulse and platform docs), documented local validation is the explicitly approved gate.
Close this issue only after the corresponding PR is verified as merged. No package release or promotion to another stable branch is authorized by this task.
Activity
chore: require Python 3.10 or newer
PierreRaybaut commentedon Oct 23, 2026
Implemented by #2, verified merged into develop as 9a45ba0.
Validation on head 35dfaad: 2 executed checks succeeded; 0 tag-only publication jobs were correctly skipped.
No package release or promotion to another stable branch is included.