Skip to content

ChecksumException with Eclipse Temurin (OpenJDK) #515

Description

@prthakre

Describe the bug
While pushing data into OpenDJ either with Eclipse Temurin (OpenJDK), server throws following exception:

com.sleepycat.je.log.ChecksumException

To Reproduce
Loading 20+ million entries with custom schema.

SEVERE: node has error: org.forgerock.opendj.ldap.LdapException: Other: com.sleepycat.je.EnvironmentFailureException: (JE 18.3.12) Environment must be closed, caused by: com.sleepycat.je.EnvironmentFailureException: Environment invalid because of previous exception: (JE 18.3.12) /home/rnd/workspace/opendj/db/userRoot com.sleepycat.je.log.ChecksumException: Location 0x1fa/0x2013734 expected 678337235 got 1219402483 LOG_CHECKSUM: Checksum invalid on read, log is likely invalid. Environment is invalid and must be closed.
org.forgerock.opendj.ldap.LdapException: Other: com.sleepycat.je.EnvironmentFailureException: (JE 18.3.12) Environment must be closed, caused by: com.sleepycat.je.EnvironmentFailureException: Environment invalid because of previous exception: (JE 18.3.12) /home/rnd/workspace/opendj/db/userRoot com.sleepycat.je.log.ChecksumException: Location 0x1fa/0x2013734 expected 678337235 got 1219402483 LOG_CHECKSUM: Checksum invalid on read, log is likely invalid. Environment is invalid and must be closed.
       at org.forgerock.opendj.ldap.LdapException.newLdapException(LdapException.java:178)
       at org.forgerock.opendj.ldap.spi.ResultLdapPromiseImpl.setResultOrError(ResultLdapPromiseImpl.java:132)
       at org.forgerock.opendj.grizzly.LDAPClientFilter$ClientResponseHandler.searchResult(LDAPClientFilter.java:300)
       at org.forgerock.opendj.io.LDAPReader.readSearchResult(LDAPReader.java:685)
       at org.forgerock.opendj.io.LDAPReader.readProtocolOp(LDAPReader.java:549)
       at org.forgerock.opendj.io.LDAPReader.readMessage(LDAPReader.java:122)
       at org.forgerock.opendj.grizzly.LDAPClientFilter.handleRead(LDAPClientFilter.java:438)
       at org.glassfish.grizzly.filterchain.ExecutorResolver$9.execute(ExecutorResolver.java:119)
       at org.glassfish.grizzly.filterchain.DefaultFilterChain.executeFilter(DefaultFilterChain.java:284)
       at org.glassfish.grizzly.filterchain.DefaultFilterChain.executeChainPart(DefaultFilterChain.java:201)
       at org.glassfish.grizzly.filterchain.DefaultFilterChain.execute(DefaultFilterChain.java:133)
       at org.glassfish.grizzly.filterchain.DefaultFilterChain.process(DefaultFilterChain.java:112)
       at org.glassfish.grizzly.ProcessorExecutor.execute(ProcessorExecutor.java:77)
       at org.glassfish.grizzly.nio.transport.TCPNIOTransport.fireIOEvent(TCPNIOTransport.java:539)
       at org.glassfish.grizzly.strategies.AbstractIOStrategy.fireIOEvent(AbstractIOStrategy.java:112)
       at org.glassfish.grizzly.strategies.WorkerThreadIOStrategy.run0(WorkerThreadIOStrategy.java:117)
       at org.glassfish.grizzly.strategies.WorkerThreadIOStrategy.access$100(WorkerThreadIOStrategy.java:56)
       at org.glassfish.grizzly.strategies.WorkerThreadIOStrategy$WorkerThreadRunnable.run(WorkerThreadIOStrategy.java:137)
       at org.glassfish.grizzly.threadpool.AbstractThreadPool$Worker.doWork(AbstractThreadPool.java:593)
       at org.glassfish.grizzly.threadpool.AbstractThreadPool$Worker.run(AbstractThreadPool.java:573)
       at java.base/java.lang.Thread.run(Thread.java:1583)

Expected behavior
No ChecksumException

Screenshots
NA

Desktop (please complete the following information):

  • OS: [Fedora 42, Docker on Unraid 7]
  • Version [4.9.3]

Additional context

Activity

  1. changed the title [-]ChecksumException with OpenJDK and Eclipse Temurin[/-] [+]ChecksumException with Eclipse Temurin (OpenJDK)[/+] on Apr 23, 2025
  2. prthakre commented on Apr 23, 2025

    @prthakre
    ContributorAuthor

    Update: The upload failed, though after a long time with Oracle JDK.
    What could be the root cause of the exception? Doesn't happen on macOS.

  3. vharseko commented on Apr 23, 2025

    @vharseko
    Member

    please provide full log

  4. vharseko commented on Apr 23, 2025

    @vharseko
    Member

    try change db-log-file-max or check disk corrupt

  5. prthakre commented on Apr 23, 2025

    @prthakre
    ContributorAuthor

    Afraid, that's the only available logs under logs folder.
    Sure, will check db-log-file-max.
    Disk corruption 😮 , this behaviour as I mentioned earlier is restricted to one particular system, not seeing this on macOS.

  6. vharseko commented on Apr 23, 2025

    @vharseko
    Member

    maybe the wrong version of docker?
    try other disk, other jdk, other file system, other os

  7. locked and limited conversation to collaborators on Apr 23, 2025
  8. converted this issue into a discussion #516 on Apr 23, 2025
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Metadata

Metadata

Assignees

No one assigned

    Labels

    No labels
    No labels

    Type

    No type

    Projects

    No projects

      Milestone

      No milestone

      Relationships

      None yet

      Development

      No branches or pull requests

      Issue actions