Skip to content

fix: require patched Node runtimes for development and CI - #3

Merged
andrewlu0 merged 1 commit into
mainfrom
andrew/node-certificate-trust
Oct 23, 2026
Merged

andrewlu0 merged 1 commit into
mainfrom
andrew/node-certificate-trust

Conversation

@andrewlu0

Copy link
Copy Markdown
Collaborator

Development installs previously accepted Node runtimes predating the October security fixes, and workflows bootstrapped pnpm or ran release metadata scripts before selecting Node. Require Node >=22.23.4 <23 or >=24.22.1 <25 for development, pin Node 24.22.1, and select it before package-manager setup and Node scripts in CI, publishing, and oracle workflows. Update the checkout, Node setup, and pnpm setup actions while retaining immutable SHA pins.

Validation with Node 24.22.1 and pnpm 9.15.0:

  • Frozen dependency installation, build, and typecheck passed.
  • All 102 unit tests and 3 oracle checks passed.
  • Workflow YAML and setup order validated; unpatched Node 24.6.0 rejected before installation.
  • Diff whitespace checks passed.

@andrewlu0
andrewlu0 merged commit 5a23445 into main Oct 23, 2026
1 check passed
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Labels

None yet

Projects

None yet

Development

Successfully merging this pull request may close these issues.

1 participant