Skip to content

chore(deps): patch security advisories - #37

Open
smmariquit wants to merge 1 commit into
mainfrom
chore/security-deps-2026-10
Open

smmariquit wants to merge 1 commit into
mainfrom
chore/security-deps-2026-10

Conversation

@smmariquit

Copy link
Copy Markdown
Collaborator

Security patch for the 2026 advisory wave (including the Oct 14 Next.js/React security release, where applicable).

What changed

  • Lockfile re-resolved within the existing semver ranges in package.json (no major version bumps).
  • Next.js moved to the patched release for its line (16.x to 16.4.2, 15.x to 15.5.28) where used.
  • Only versions published before 2026-10-16 (at least 7 days old) were allowed, and install scripts were disabled during resolution, to avoid pulling in a freshly compromised package from the ongoing npm worm campaigns.

Audit (critical / high / moderate / low)

Lockfile Before After
bun.lock 1 / 19 / 12 / 2 0 / 0 / 0 / 0
package-lock.json 1 / 9 / 1 / 0 0 / 0 / 0 / 0

Remaining highs/moderates mostly sit in dev tooling and need major-version upgrades; run npm audit / pnpm audit / bun audit for the list.

Verification: lockfile consistency checked with a frozen install (npm ci --dry-run / pnpm install --frozen-lockfile / bun install --frozen-lockfile). Not built locally; please check the CI / preview deployment on this PR before merging.

Re-resolve lockfile within existing semver ranges and move Next.js to
its Oct 2026 security release where used. Resolution limited to
versions published before 2026-10-16, with install scripts disabled.

Audit before -> after (critical / high / moderate / low):
  bun.lock: 1 / 19 / 12 / 2 -> 0 / 0 / 0 / 0
  package-lock.json: 1 / 9 / 1 / 0 -> 0 / 0 / 0 / 0
@vercel

vercel Bot commented Oct 23, 2026 •

Copy link
Copy Markdown

The latest updates on your projects. Learn more about Vercel for GitHub.

Project Deployment Actions Updated
uplbtools-me Ready Ready Preview Oct 23, 2026 9:32am UTC

Request Review

Comment thread package.json
@@ -13,6 +13,6 @@
"astro": "astro"
},
"dependencies": {

Copy link
Copy Markdown

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

Astro 7.4.0 requires node >=22.22.0 (see its engines in package-lock.json), but engines.node here is still >=22.12.0. Node 22.12 to 22.21 passes the declared range and then fails npm ci or the build. Raise engines.node to >=22.22.0. AGENTS.md and README.md also still say "Astro 6" and "Node ≥ 22.12".

@claude

claude Bot commented Oct 23, 2026

Copy link
Copy Markdown

Review summary: one finding. Astro 7.4.0 requires Node >=22.22.0, but package.json engines.node is still >=22.12.0, and AGENTS.md and README.md still say Astro 6 and Node >=22.12. Nothing else found in the lockfile changes.

This branch was successfully deployed

1 active deployment
Preview — 3f731575 Deployed Oct 23, 2026 by vercel[bot]
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Labels

None yet

Projects

None yet

Development

Successfully merging this pull request may close these issues.

1 participant